All Products 
Username / Customer#
Password
Log In
 Hi,  |  Log Out
  • Site Search
  • Domain Search
  • WHOIS Domain Check
24/7 Support: (480) 505-8877
Hablamos Español
9 AM to 9 PM IST
7 days a week
Go Daddy Support

Search help articles, forums, and discussion groups

What do I do when I receive an Internal Server Error?

Date Submitted: 5-10-2013

Error Message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/1.3.33 Server at mydomain.com Port 80

Cause:

This error can be caused by a variety of issues but is most likely caused by a corrupt .htaccess file. Check to see if there is an .htaccess file in the directory where the error is being generated or any directory above in the tree. If so, temporarily rename the .htaccess file and refresh the page. If the error does not reappear, the .htaccess file is the issue. Repair the file or leave it disabled.

If you encounter further issues with the renamed .htaccess file, revert its name, and try restoring it from a backup.

Most of the time .htaccess issues are caused by trying to overwrite PHP settings, being uploaded in binary format or permissions issues.

Resolution:

Be sure to upload .htaccess files in ASCII mode

Set the permissions to 644, which makes it usable by the server, but prevents it from being read from a browser.

If you are trying to make changes to PHP settings, be sure to make said changes to the php.ini or php5.ini file (depending on the version you are using).

For more information see Working with Error Logs.

Rate This Article:
Related Topics:

Have a question about the content of this article?